Android 13 file system compatibility?

I have a weird issue that may have started when I upgraded to the latest version of Max2d. (The update with script components) The issue is not really a problem until you have a project that you want to export to APK or just want to do some house cleaning to reduce the game’s size.

Stay with me here because this is not a simple problem.

Ok, as you may or may not know, in Android 13 and up, they added increased file system security. Basically, they locked down the Android/data partiton even more than it was already. In the latest version of android, this folder is not accessible without root permission. Of course, applications can still access their own subfolder within Android/data.

As most of you probably know, max2d saves its projects under Android/data. (You know where I’m going with this :wink:)

So I made this awesome game, uploaded it to the playground without issue. :muscle::muscle:The game plays fine in the playground. But i noticed it loads rather slow. I had a lot of sounds and images that were no longer in use. Basically, the game had not been cleaned up and it needed it badly.

Back up a second: This was happening right when the latest max2d update was released. I’m not sure if this would have been an issue on the previous version or not. However, the evidence is pointing the finger at the latest update. I’ll explain more below.

Ok. So I attempt to clean up the project. Here are the problems I ran into. They are not specific to my game, unfortunately. It seems all projects have these issues for me now:

  1. While trying to clear up the project, I removed sprites and sounds that I was not using from inside max2d. Once they were no longer used in my project, I attempted to delete them from the filesystem. I’ve done this before so it was very frustrating that i couldnt delete them. They just wouldn’t delete.

  2. I had some success with cleaning up my project, but about 50% of the files just wont go away. At this point, I decided to export the game to an APK. After a few failed attempts, it finally worked. Well, I got the email from max2d with an Apk file at least. It installed fine, but when I tried running it, it did nothing. Just a white screen. So I look into my apk file, and I noticed the is really small. I extract the contents, and it is missing most of my resources. No wonder it didn’t run. What I discovered however, is that the zip file I sent to the server when I requested the APK was exactly the same! It was missing most of my project.

Turns out, when I attempt to manually zip my project folder, it does the exact same thing! The zip file is missing the majority of the folder contents.

  1. During all this, I discovered something. Assets that I added before the last update have no issues. I can access them, zip them, I can even play the audio files and view the sprites from the project folder. Any asset I’ve added since the update, works fine in max2d, (the sprites work when I run my game, the audio plays fine etc.) But none of them are accessible from the filesystem. I cant zip them, I cant play the audio files outside of max2d, and they dont make it inside the apk. The images are not even viewable outside of max2d.

To make this more complicated, this is a new phone and in the last month or so, it has completed two forced updates. The release notes say “security updates” and nothing else. Ugh.

Is anyone having similar issues with the latest update and/or with Android 13 and Max2d???

This has been really frustrating! I even purchased the nicest file exploring application on the playstore just to make sure it wasn’t the free app I was using.

Surely someone is having these issues besides me???

Max2D Should Definitely Make A Sub-Folder In Emulated/0(originally where you start)